HSRP – Mise en place

cisco logo

HSRP – Mise en place

cisco logo

Hot Standby Router Protocol (HSRP) est un protocole propriétaire de Cisco implémenté sur les routeurs et les commutateurs de niveau 3 permettant une continuité de service. HSRP est principalement utilisé pour assurer la disponibilité de la passerelle par défaut dans un sous-réseau en dépit d’une panne d’un routeur.

HSRP est décrit dans la RFC 22811.

Source : wikipedia

Exemple : 

schema cisco hsrp

Explication :

Avec cette configuration d’infrastructure, il y aura continuité de service si l’un des routeur tombe en panne.

Cela permet d’avoir une redondance au niveau des liens vers le F.A.I

Configuration R1

hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
ip tcp synwait-time 5
!
track 10 ip sla 1 reachability
!
!
!
!
interface FastEthernet0/0
 description LAN Interface
 ip address 192.168.1.1 255.255.255.0
 duplex half
 standby 1 ip 192.168.1.3
 standby 1 priority 101
 standby 1 preempt
 standby 1 track 10 decrement 5
!
interface Ethernet1/0
 description WAN interface
 ip address 1.1.1.1 255.255.255.0
 shutdown
 duplex half
 standby 0 preempt
 standby 1 ip 1.1.1.3
 standby 1 priority 101
 standby 1 track 10 decrement 5
!
interface Ethernet1/1
 no ip address
 shutdown
 duplex half
!

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.100
no ip http server
no ip http secure-server
!
!        
ip sla 1
 icmp-echo 1.1.1.100 source-interface Ethernet1/0
ip sla schedule 1 life forever start-time now
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Configuration R2

hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
! 

!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 description LAN Interface
 ip address 192.168.1.2 255.255.255.0
 duplex half
 standby 1 ip 192.168.1.3
 standby 1 preempt
!
interface Ethernet1/0
 description WAN Interface
 ip address 1.1.1.2 255.255.255.0
 duplex half
 standby 1 ip 1.1.1.3
 standby 1 preempt
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.100
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!         
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

référence :

https://www.networkstraining.com/cisco-router-hsrp-configuration/

Electrotuto

Passionné par les nouvelles technologie, notamment l’électronique et tout ce qui se rapporte de prés ou de loin a ce domaine. Arduino et photographie son mes passe temps favoris.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

Post comment